Spring for Apache Kafka 3.2.2

Spring for Apache Kafka(spring-kafka)プロジェクトは、コア Spring の概念を Kafka ベースのメッセージングソリューションの開発に適用します。これは、メッセージを送信するための高レベルの抽象化として「テンプレート」を提供します。また、@KafkaListener アノテーションと「リスナーコンテナー」を備えたメッセージ駆動型 POJO のサポートも提供します。これらのライブラリは、依存性注入と宣言型の使用を促進します。これらすべての場合において、Spring Framework での JMS サポートおよび Spring AMQP での RabbitMQ サポートとの類似点が見られます。

機能

  • KafkaTemplate

  • KafkaMessageListenerContainer

  • @KafkaListener

  • KafkaTransactionManager

  • 組み込み kafka サーバーを備えた spring-kafka-test jar

Kafka クライアントと Spring Boot の互換性

サポートされているバージョンについては、上のサポートタブを使用してください。

Spring for Apache Kafka は、純粋な java kafka-clients jar に基づいています。以下は互換性マトリックスです。

Spring for Apache Kafka バージョン Spring Integration(Apache Kafka バージョン用)kafka-clientsSpring Boot
3.2.x6.3.x3.7.03.3.x
3.1.x6.2.x3.6.03.2.x
3.0.x6.0.x/6.1.x3.3.2 3.6.0 へ 3.0.x/3.1.x
2.9.x5.5.x3.2.3 ~ 3.6.02.7.x (管理対象外)
2.8.x5.5.x3.0.0 2.6.x または 2.7.x(サポート終了)
2.7.x5.5.x2.7.0 - 2.8.1 2.4.x または 2.5.x(サポート終了)
2.6.x5.3.x または 5.4.x2.6.0 - 2.8.1 2.3.x または 2.4.x(サポート終了)
2.5.x3.3.x2.5.1 - 2.8.1 2.3.x(サポート終了)
2.4.x3.2.x2.4.1 2.2.x(サポート終了)
2.3.x3.2.x2.3.1 2.2.x(サポート終了)
2.2.x3.1.x2.0.1, 2.1.x, 2.2.x 2.1.x(サポート終了)
2.1.x3.0.x1.0.2 2.0.x(サポート終了)
1.3.x2.3.x0.11.0.x, 1.0.x 1.5.x(サポート終了)

IMPORTANT : このマトリックスはクライアントとの互換性です。クライアント / ブローカーの互換性に関する完全な説明については、Kafka 互換性マトリックス [Apache] (英語) を参照してください。

  • 2.0 より前の Spring Integration Kafka バージョンは Spring for Apache Kafka プロジェクトよりも前のものであるため、それに基づいていませんでした。

バージョン管理に maven または gradle を使用する場合、これらのバージョンは推移的に参照されます。

  • Spring Boot 1.5 (EOL) ユーザーは 1.3.x を使用する必要があります (Boot 依存関係管理はデフォルトで 1.1.x を使用するため、これをオーバーライドする必要があります)。

  • Spring Boot 2.1 (EOL) ユーザーは 2.2.x を使用する必要があります (Boot 依存関係管理は正しいバージョンを使用します)。

  • Spring Boot 2.2 (EOL) ユーザーは 2.3.x を使用する必要があります (Boot 依存関係管理は正しいバージョンを使用するか、バージョンを 2.4.x にオーバーライドします)。

  • Spring Boot 2.3 (EOL) ユーザーは 2.5.x を使用する必要があります (Boot 依存関係管理は正しいバージョンを使用するか、バージョンを 2.6.x にオーバーライドします)。

  • Spring Boot 2.4 (EOL) ユーザーは 2.6.x を使用する必要があります (Boot 依存関係管理は正しいバージョンを使用するか、バージョンを 2.7.x にオーバーライドします)。

  • Spring Boot 2.5 (EOL) ユーザーは 2.7.x を使用する必要があります (Boot 依存関係管理は正しいバージョンを使用します)。

  • Spring Boot 2.6 ユーザーは 2.8.x を使用する必要があります (Boot 依存関係管理は正しいバージョンを使用します)。

  • Spring Boot 2.7 ユーザーは使用する必要があります 2.8.x、または 2.9.x (Boot 依存関係管理では 2.8.x バージョンが使用されます)。

Boot 2.7.x で 2.9.x を使用するには、Spring Boot の依存関係を上書きを参照してください。

  • Spring Boot 3.0.x は kafka-clients 3.3.2 を使用します

  • Spring Boot 3.1.x は kafka-clients 3.4.1 を使用します

Spring Boot でサポートされているバージョン

Spring Initializr

プロジェクトのクイックスタート

サポートの取得

Tanzu Spring は、1 つのシンプルなサブスクリプションで OpenJDK ™、Spring、Apache Tomcat ® のサポートとバイナリを提供します。

さらに学習したい方に (英語)

今後のイベント

Spring コミュニティで今後開催されるすべてのイベントをチェックしてください。

すべて表示 (英語)